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DDeellttaa22DD  44..00  

QQuuiicckk  ssttaarrtt  gguuiiddee  
 

DECODON GmbH 

www.decodon.com 

 

Thank you for using Delta2D, the software package with leading technology for easy and 

reliable analysis of 2D gel images. 

 

The aim of this guide is to show how to analyze gel images with Delta2D. We will start 

with raw image data and finish with quantitative results and visualizations that are ready 

for presentation. We use an example project consisting of six gel images and an 

additional artificial proteome map to illustrate the steps of a typical analysis. 

If you are interested in analysing DIGE gels, please also read the respective inserted 

green notes and the sections with green headlines, otherwise skip them. 

 

The completely analyzed example project comes with your installation of Delta2D. In this 

guide, however, we will start with the raw data. Please go to www.decodon.com 

/Support/manuals.html and download the Delta2D sample data (Delta2D-samples.zip, 

8.89 MB) we are using in this guide. Delta2D-samples.zip contains six gel image files and 

match map files for the warping. 

 

Note:   

If you need more detailed information about Delta2D, please consult the manual of Delta2D. 

You can access it through the Delta2D help menu or as a PDF file located in the installation 

directory. In Windows, there is a direct link to the manual in the Start menu. The manual is 

also available for download and for online browsing! 

  

 

To learn more about Delta2D please do not hesitate to contact us by email to  

support@decodon.com or by phone at +49 (0) 3834 515 230.  

mailto:support@decodon.com
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AAnnaallyyzziinngg  GGeell  IImmaaggeess  iinn  jjuusstt  66  SStteeppss  

Setup Project  

Setting up traditional and DIGE experiments: Import your gel images into Delta2D and 

arrange them into projects.  

Setup Gel Image Warping 

Setup direct warpings such that all gel images in the project can be connected, directly or 

indirectly.  

Create Direct Warpings  

Find and review match vectors for directly connected gel image pairs to eliminate running 

differences between these gels. 

Create the Consensus Spot Pattern 

Do consistent spot detection across the whole project. 

Analyze Expression Profiles 

Find spots with relevant expression profiles. 

Present Results 

Create reports or provide results to other applications for presentation or further analysis. 
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  SSeettuupp  PPrroojjeecctt    
 

We start with the raw data files on the hard disk. The example experiment consists of a 

control sample, and two samples 1 and 10 minutes after treatment with a chemical 

compound, respectively, with two replicates of each sample: 
 

 

Image file  

 

Sample 

control_01.gel  control (replicate 1) 

control_02.gel  control (replicate 2) 

1min_01.gel  1 minute after treatment (replicate 1) 

1min_02.gel  1 minute after treatment (replicate 2) 

10min_01.gel  10 minutes after treatment (replicate 1) 

10min_02.gel  10 minutes after treatment (replicate 2) 

 

Note:   

If you have not already done so, please download the example data that we use in this 

guide www.decodon.com/Support/Documentation/Delta2D-samples.zip. Unpack the archive. 

It contains six gel images and match map files for the warping. 

  

Start Delta2D 

Start on Windows by clicking on 'Start' > 'Programs' > 'DECODON' > 'Delta2D', on other 

systems in accordance to the respective installation. Delta2D opens and you are asked to 

open an existing project or to create a new one.  

 

Projects are collections of gel images, and analysis data (spot boundaries, quantities etc.). 

So far, there is one project only: The demonstration project that comes with the 

installation of Delta2D. 

 

  

 

 

 

 

 

 

http://www.decodon.com/Support/Documentation/Delta2D-samples.zip
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When Delta2D has started, this dialog provides a list of available projects  
in the current pool plus the option to change the pool. 

Create a new data pool 

Delta2D keeps all data related to your current gel images, including the images 

themselves, in one folder on your hard disk. We call this folder a 'Pool'. It contains several 

subfolders and data files that are managed by Delta2D. To keep your experimental data 

organized, we recommend creating a new pool for every new experimental context. 

 

1. Click on the button 'Change Pool' and navigate to a folder where you want to 

store your new pool. 

2. Right click and select 'Create Folder', then click on the new folder or select it 

and press F2. Type in a name for this new pool and confirm the input with 

ENTER. 

3. Click on OK and confirm the following dialog with 'Yes'. 

 

Note:   

Choose different pool paths for your different experiments to separate them from each 

other and from the demonstration data. Furthermore it is easy to copy, move, or backup the 

different pools. Avoid working with network drives. 

  

Create a new project 

The 'Projects' dialog appears again showing an empty list of available projects. The title 

bar of the dialog displays the path to the pool you are working in. 
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Click on the 'New' button to create a new project. A dialog opens requiring some project 

details. Provide the name and the author of the project and insert a short description. Do 

not check the "Use Internal Standard" checkbox. Press 'OK' to create the new project. 

Select the new project in the "Projects" dialog and press 'Open'. Whenever a new project 

is opened, two new, empty groups are automatically created. 

 
Note:   

For DIGE projects activate the checkbox 'Use Internal Standard'. 

  

Set up groups for the gel images 

It is recommended to organize your gel images into groups. Usually, your project will have 

one group for every set of replicates in the experiment. 

We will now create the three groups for our experiment. There are already two groups 

present which you should see in the Light Table (window by default in the right part of 

the screen). We will simply change the names of these two groups: 

1. Right-click on the first group and choose 'Properties' from the context menu. 

2. Replace the group's name by 'control'. If you want, choose another color for 

the group. Confirm with OK. 

3. Repeat this for the second group assigning the name '1min'. 

 

To create a new group, select 'Project' > 'Add Group' from the menu and name it 

'10min'. Choose another color if you want. You can permute, add or delete groups at any 

time.  

Add gel images to the new project 

Right-click on group 'control' and select 'Add New Gel Images...' from the context menu 

to add images to this group. The gel manager opens, showing all gels in the current pool. 

Since the pool has just been created it is empty and we have to import gel images. Click 

on the button 'Import' and go to the directory where you unzipped the example data 

from our web site. There are sample gel images in a sub folder called 'samples'. Select the 

two images 'control_01' and 'control_02' by using the left mouse button in combination 

with the CTRL-Key. Click on 'Next'. In this step you can edit names and other descriptive 

data for an image, and do some basic manipulations such as rotating, mirroring or 

inverting the image. Click on 'Next' again to repeat this for the second image.  
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You can click on 'Finish' any time if you want to import the images without further 

changes. Import the sample images '1min_01', '1min_02', '10min_01' and '10min_02' 

into their respective groups. Now every set of replicate images is located in a separate 

group. The project will now appear as in the following figure: 

 

 
The Delta2D Light Table (right) with the six sample gel images organized in three groups  

('control', '1min', and '10min'). 

 

Setting up a DIGE analysis project 

For DIGE and other multiplex experiments, first follow the steps outlined above, i.e. 

organize gel images into groups according to the sample that they show.  

The layout of a simple DIGE experiment with two samples A and B on two gels is shown 

below. Replicates are put into the same group. The internal standard images are put into 

the group 'standard'. 
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Image file 

 

Dye 

 

Gel 

 

Sample 

 

Group 

g001_cy2.tif Cy 2 Gel I Internal standard, gel I Standard 

g001_cy3.tif Cy 3 Gel I Sample A, replicate 1 Sample A 

g001_cy5.tif Cy 5 Gel I Sample B, replicate 1 Sample B 

g002_cy2.tif Cy 2 Gel II Internal standard, gel I Standard 

g002_cy3.tif Cy 3 Gel II Sample B, replicate 2 Sample B 

g002_cy5.tif Cy 5 Gel II Sample A, replicate 2 Sample A 
 

Delta2D applies the internal standard for quantitation. This means that a spot's quantity is 

divided by the quantity of its corresponding spot on the internal standard image on the 

same gel. Hence it is important to let Delta2D know which images belong to the same gel 

and which image shall serve as the internal standard image. 
 

1. Configure the project to use internal standard images 

Select 'Project Properties' from the 'Project' menu. Then check the 'Use Internal 

Standard' checkbox and click 'OK' to apply the settings and close the Project 

Properties dialog. 
 

2. Assign gels to gel images 

We now have to tell Delta2D which images come from which gel, and where the 

internal standard images are.  

Choose 'Gels' > 'Gel Image Attributes'. Select the 'Gel' tab. You see a list of gels 

(designated by roman numerals) and the images that come from each gel. Rename 

the existing sample gel names or add new entries assigning new names. Then right 

click on an image to assign it to a specific gel.  

Alternatively, you can drag an image and drop it onto another gel. Arrange the 

images to reflect your experimental design. 
 

3. Identify internal standard images 

For each gel, you see a column of radio buttons. Select the radio button next to 

the image that contains the internal standard (usually, this will be the Cy2 image). 
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  SSeettuupp  GGeell  IImmaaggee  WWaarrppiinngg    
 

Background: Why is warping  

important for 2D gel image analysis? 

Usually, spots from the same protein appear at slightly different positions on different 

gels. These positional differences are the main reason for inefficiency in 'traditional' 2D 

gel image analysis packages.  

 

  
Gel image with overlaid grid The same gel image after warping 

 

If you are used to classical 2D gel analysis packages, you might know those long and 

tedious editing sessions for spot matches and spot boundaries that were found 

"automatically" by the software.  

Delta2D's image warping eliminates these running differences between 2D gel images 

before doing spot detection or quantitative analysis using an image processing method 

called Warping. The result is like having perfect gels: after warping, corresponding spots 

have the same position.  

DECODON pioneered the use of image warping in 2D gel analysis with the release of 

Delta2D version 1.0 in 2000. 
 

Note:   

DIGE and other multiplex methods allow you to co-migrate multiple samples on the same 

gel. Thereby they mitigate the problem of differing spot positions. However, as soon as an 

experiment contains more than one gel, gel analysis software will have to deal with different 

migration positions. 
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Here you see a combined image that is made from two gels. One is colored in orange, the 

other one in blue. In the dual channel image without warping it is hard to find 

corresponding spots and do comparisons of expression patterns. 

 

  
Two gel images, overlaid into a dual 

channel image, not warped. 

Two gel images, overlaid into a dual channel image, after 

warping. Differences in expression levels are clearly visible. 

Warping allows Delta2D to assign corresponding image 

positions across a whole set of images. This enables, for 

example, 100% Spot Matching and Image Fusion. 

 

After the warping, the dual channel image gives valuable insight for comparing the spot 

patterns qualitatively. Blue spots are stronger on gel A, orange ones on gel B. Dark colors 

mean that spots have roughly the same intensity on both images. 

But the advantages of warping go far beyond the making of dual channel images. The 

effect of applying image warping is as if you had made perfect 2D gels: those would have 

all proteins migrating exactly to the same position. And because Delta2D knows about 

pixel-by-pixel correspondences between images, a number of Delta2D's other core 

technologies are now available: 
 

 100% Spot Matching  

Delivers you higher statistical confidence for the analysis of expression profiles. 

 Image Fusion  

Lets you combine multiple images to produce, for example, average images. 

 Proteome Maps  

Use union fusion images to e. g. store protein identifications.  

 Color coding  

Analysis of expression profiles with spot Color Coding combines image fusion and 

100% spot matching to deliver a high-level overview of groups of proteins having 

similar profiles.  
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Delta2D's SmartVectorsTM
 technology produces a warping automatically, based on 

similarities between regions on gel images. 

Defining a warping strategy 

The warping for a whole experiment in Delta2D is based on pairwise warpings between 

gels. You do not have to produce match vectors for every possible gel image pair in your 

project: Given a warping between gel A and gel B, as well as a warping between gels B 

and C, Delta2D will automatically create an implicit warping between A and C.  

 

A 'Warping Strategy' contains the definition of pair-wise warpings that Delta2D should 

use to construct the overall warping. It can be flat or hierarchical. 

 

The Group Warping Strategy is suitable for most projects with replicate groups. The 

general guideline for setting up a warping strategy is to connect similar gels directly, and 

to make sure that every possible gel pair can be warped by combining a few direct 

warpings. See the manual section 'Defining a Warp Strategy for the Complete Project' for 

more information. 

 

With the Group Warping Strategy you warp both gels within every replicate group using 

the automatic warp mode. Connect the replicate groups by warping the first gel of the 

'control' group (control_01) to the first gels of the '1min' and '10min' groups, again using 

the automatic warp mode. 

 

Switch to the second step of the 'Workflow' window called 'Setup Gel Image Warping' 

and click on the 'Warp Strategy...' link to open the Delta2D Warping Strategy Manager. 

Alternatively you can open it via the menu: 'Gels' > 'Set Warp Strategy...'. Select the 

Group Warping Strategy. Automatic warping for warpings within as well as between 

groups is automatically taken as default setting. Press 'OK' to apply the selected strategy. 

 

 

 
Implicit gel image warping 

 

gel A 

 

gel B 
 

gel C 

http://www.decodon.com/Support/Documentation/3.4/html/manualch5.html#x11-1140005.10
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Note:   

You could also define the warping strategy by dragging images onto each other in the 

'Warping Setup' window. Using the Warping Strategy Manager is, however, easier and 

faster. 

  

 

Automatic warping employs the SmartVectorsTM
 technology and delivers the result as a set 

of match vectors that connect corresponding spots. Always check the resulting dual 

channel image and if necessary improve the warping iteratively as described later in this 

document (see also 'Create Direct Warpings'). 

 

Note:   

The Strategy Manager overrides previous manual assignments of warping methods. So apply 

it after having organized a new project and be careful when applying it again later. Existing 

sets of match vectors are not affected. 

  

 

 
Warping strategy manager 
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Open the 'Warping Setup' window by clicking on the link 'Setup direct warpings' (or 

'Window' > 'Warping Setup') to check whether the warping strategy has been applied 

correctly such that all images are connected:  

 

  

Setting the warp strategy. The Warping Setup window after applying the Group 

Warping Strategy (Grid Layout). 

 

As explained above, the warping strategy uses automatic warps to connect images within 

the same group, and to connect the first image in every group to control_01. The 

'Warping Setup' reflects this: a line connecting two images means that the images should 

be warped directly. All the other gel image pairs can be warped by combining one or 

more of these warpings if each image has at least one connection to one of the other 

images of the project. 

 

As a guideline, you can think of the yellow icons as showing you where you have to do 

work for the warping step. By creating match vectors for each of these image pairs, we 

allow Delta2D to warp the whole project.  
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Setting up a warping strategy for DIGE  

and other multiplex projects 

Delta2D offers a special warping strategy for DIGE and other multiplex experiments that 

use an internal standard. Within the same gel, we will not have to do any warping 

because samples are co-migrated. For warping between gels, we use the internal 

standard images because they always show the same internal standard sample which 

makes them very easy to warp. 
 

Note:   

Before you start, make sure that you have checked 'use internal standard' in project 

properties, and assigned gels and internal standard images. 

  
 

Choose 'Warp Strategy...' from the second step ('Setup Gel Image Warping') of the 

'Workflow' window to open the Delta2D Warping Strategy Manager. Select the In-Gel 

Standard Warping Strategy. Warp mode within gels should be set to 'Identical', Warp 

mode between gels to 'Automatic'. Then press 'OK' to apply the selected strategy and 

close the 'Warping Strategy Manager'.  
 

 

Note:   

Warp mode 'Identical' means that Delta2D will take the images as-is, without doing any 

warping. This is suitable for images from the same gel. Of course, you can change this 

setting (e.g. if there is a minor shift between the different images).  

  

 
Warp Manager  In-Gel Standard Warping Strategy 
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  CCrreeaattee  DDiirreecctt  WWaarrppiinnggss    
 

SmartVectorsTM: Find Match Vectors Automatically 

The goal of this step is to produce a warping that aligns spots on one image with 

corresponding spots on the other image. In the 'Warping Setup' window, each yellow or 

green line with a yellow or green icon connecting two images represents one direct 

warping using so-called match vectors to align the images

Technology automatically produces match vectors. You can batch all the warpings so that 

a first iteration using the SmartVectors  is done in the background:  

From the third step of the Workflow 'Create Direct Warpings' you can invoke the 'Job 

Manager' by clicking on the link for it. In the Job Manager click the 'Run' button to let it 

monitor and perform all automatic warping jobs. 

 

In order to open the completed warpings you can use 

the table below 'Review Direct Warpings' in the step 3 

of the Workflow: Double-click on a row where the 

symbol in the yellow icon changed from a toothed 

wheel to two arrows:  

A Dual View window (the dual channel image of these 

gel images) opens and shows the combination of the 

two images of the respective table row. Thus, you can 

see the differences in spot positions at a glance: black or 

gray spots have about equal volume in both images. 

Orange spots are stronger on the first image while blue 

spots are weaker. The more their color tends to one extreme, the bigger the difference is 

in expression. 
 

Of course you can navigate any time through the dual channel image, zoom in and out or 

view the single images only. You can also correct the presentation of the images by 

choosing 'Histograms...' ( ) from the menu 'Images' and by using the sliders to adjust 

the settings and clicking on the 'Equalize Image Button' ( ) in the tool bar to make sure 

that both images are balanced. Changes will affect the visualisation only, while 

quantification will always be done on the raw images. Please also check if the gel image 

background has been hidden by using the 'Show/Hide Background' button ( ) in the tool 

 
Dual Channel image  

of two unwarped gel images 
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bar. This adjustment helps to better see the differences in spot positions. Confirm with 

 

 

 
Histogram settings dialog 

 

Now press the warp button ( ) and Delta2D will warp the orange image in accordance 

to the match map using the exact warp mode. In the resulting warped view, it is usually 

easy to see if all corresponding spots are aligned. Regions that are not sufficiently aligned 

show up as similar spot patterns in the blue and in the orange part of the image. Delta2D 

will only create match vectors in regions where it is reasonably certain that they 

correspond to each other. You can unwarp the images (press unwarp ) whenever you 

want to review the match vectors with respect to the original images. 

 

Note:   

Delta2D distinguishes between match vectors that were set by hand (shown as solid lines), 

and those that were created automatically (shown as dashed lines). By 'approving' a match 

vector you declare that it was checked by you, so it can be used to guide the finding of 

more match vectors. 

  
 

If there are regions that are not properly warped yet, you can delete all the match vectors 

(see below) in the particular regions and use the 'Find Match Vectors' button to let 

guide 

the process of finding new ones: 

Press the 'Find Match Vectors' button. Delta2D will ask you what to do with the vectors 

that were automatically created in the previous step: You can decide to use them as basis 

of another iteration with SmartVectorsTM technology or to reject them. 
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Alternatively, you can create, delete or change match vectors manually as described in the 

following section. 

 

Note:   

As soon as you have approved all the match vectors for the gel image pair, the color of the 

icon for the respected pair will change from yellow to green, meaning that you have already 

worked with the match vectors. It is good practice to approve all match vectors when you 

are finished with a gel pair (use Matches -> Select Non-Approved, and then Matches -> 

Approve Selected) as this makes it easier for you to notice the status of a warping at a 

glance. 

  

 

Creating, deleting, and changing match vectors by hand 
 

Note:   

In order to work with match vectors, you have to select the Match Vector Tool first. Click on 

the top-most button in the vertical tool panel at the left of the dual view window.  

  

 

Sometimes you will want to correct or improve the match vectors that were found 

automatically by Delta2D. The general approach is to work with whole image regions (as 

opposed to single spots). If one or more match vectors in a region are not correct, you 

just delete all match vectors in that region and press 'Find Match Vectors' again to find 

better ones; vectors from surrounding regions will guide the process. 
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The Dual View after Warping 
 

Of course, you can set and change all match vectors by hand if you want: 

 

 Selecting a single match vector 

You can select a single match vector by clicking on it. Selected match vectors are 

highlighted. 

 Selecting match vectors in a region 

Drag a rectangle with the mouse (keep the left mouse button pressed). All vectors in 

that rectangle will be selected. 

 Deleting match vectors 

Right click on a match vector and choose 'Delete' or 'Delete Selected' from the menu. 

This will delete the selected or all selected match vectors, respectively. 

 Setting a new match vector 

Click first on the spot in the orange image, then on the corresponding spot on the 

blue image. Hold down the CTRL key while you click in order to let automatically snap 

the ends of match vectors to spot centers. 
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 Changing a match vector 

Drag one end of the match vector in order to change it. Hold down the CTRL key 

while you drag in order to switch off spot snapping. 

 

Note:   

You can undo match vector operations by selecting 'Undo' from the Edit menu. 

  

 

Click on the Warp button to apply your new match vectors. You can iteratively add, 

correct or delete match vectors until the result is satisfying.  

Verifying the results 

Since the quality of the whole analysis relies on the exactness of warping, it is worth 

working carefully in this step of analysis. In order to control the quality of the warping 

step, please check this list: 

 

 In the Warping Setup window you should see green lines with green icons only. 

 For each gel pair with a green connection, open the Dual View by double-clicking on 

the respective icon and check the warped dual channel image. 

 

Even if you set the warp mode to automatic you should still review the resulting warping 

in the Dual View to check if you are satisfied or if a correction is necessary. 

 

Note:   

The demo data set includes prepared match maps. To save time, just import the respective 

match map for a pair of gel images in the Dual View. In the menu choose Matches -> 

Import. If the blue match vector ends point into orange spots and vice versa the match 

vectors have the wrong direction and you need to convert them by choosing 'Matches > 

Invert'. 
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  CCrreeaattee  tthhee  CCoonnsseennssuuss  SSppoott  PPaatttteerrnn    
 

Delta2D's 100% Spot Matching is based on advanced image processing methods. It was 

introduced by DECODON in 2003. For a general presentation of this approach, please go 

to http://www.decodon.com/Solutions/Delta2D/100_Percent_Spot_Matching.html. 

100% Spot Matching produces complete expression profiles for every protein. This leads 

to significantly improved statistical confidence, so you can, for example, identify more 

biomarker candidates from the same experiment. Other approaches to spot detection and 

matching (e.g. separate spot detection on every gel image) lead to inconsistencies like 

missing values in expression profiles, and ambiguities in the profiles themselves.  

 

Based on a completely warped project, the quantitative analysis in Delta2D consists of 

three steps: 

 

1. Image fusion to produce an image that shows all spots in the experiment 

2. Spot detection on fused image to produce a 'consensus spot pattern' 

3. Transfer of spots to the original images where they are quantified. 

Generating a fusion image 

The fusion image shows all spots of the experiment and serves as the basis for consistent 

spot detection and matching. Image fusion works by warping a set of images and then 

combining their intensities pixel by pixel into a new image. The result is an artificial gel 

image that has realistic spot shapes and combines essential characteristics from the 

original images.  

 

Note:   

There are many interesting applications of image fusion. For example, fusion images can be 

used to create a 'proteome map' i.e. a condensed visualization of all analysis results where 

you can collect your spot annotations. With average fusion, experimental variation can be 

compensated by combining several replicates into one average image. Large numbers of 

gels can be reduced to a single representative one. 

  

 

Let us create a fusion image of our experiment: Switch to the fourth step in the Workflow 

window called 'Create the Consensus Spot Pattern' and click on the 'Fuse all images...' 

link to open the 'Image Fusion' dialog: Select 'control_01'as 'Master Gel Image' and 

http://www.decodon.com/Solutions/Delta2D/100_Percent_Spot_Matching.html
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'Union' as Fusion Type, since the union fused image will include all the spots of the 

experiments. Leave all of the other settings. Click on 'Fuse' and a new image will be 

created and placed into a new group called 'Fused Images'. 

Open the new fusion image by clicking on 'Open Fused Image using Union...' in the 

fourth Workflow step. A Dual View window opens showing the single view of the fused 

image only. 

 

Note:   

If an image is not connected to any of the other images or is only connected with the 

'automatic' warp mode and you have not started the Automatic to find match vectors so 

far, you won't be allowed to fuse those images. If necessary, please check your warping 

strategy in the 'Warping Setup' window ('Window' -> 'Warping Setup') once again. 

  

 

You can see that the fusion image looks like a real gel image. The natural spot patterns 

result from combining the images pixel-by-pixel using a weighted average function. Most 

importantly, the 'Union' fusion image contains all spots of the project's gel images, even 

those that occur only on one or two of the images. 

 
Note:   

For DIGE projects you can exclude the internal standard images (typically the Cy2 labelled 

images) from the fusion since they do not carry information which is not included in the 

sample images. 

  

 

Detecting spots on the fusion image 

Keep the Dual View open and click on the link 'Detect Spots on Fused Image...' in the 

'Create the Consensus Spot Pattern' in the Workflow (alternatively choose 'Spots' -> 

'Detect Spots on Fused Image' in the Dual View). A new dialog opens where you have 

access to the spot detection parameters. 

 

Just accept the proposed parameter values since they are quite reasonable in most cases. 

Confirm this dialog by pressing OK and let Delta2D detect the spots. 
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Note:   

The default parameters for the spot detection are derived from the actual images and result 

in a very sensitive spot detection. This is because it is much quicker to filter out false positive 

rather than adding new spots one-by-one. 

  

Editing spots on the fusion image 

You can correct the results of Delta2D's automatic spot detection by setting "markers". By 

using markers you can control where a new spot should be detected. Delta2D will then 

compute the new boundary accordingly. There are three basic operations for spot editing: 

adding a new spot, splitting a spot, and joining two or more spots. In any case Delta2D 

will compute spot boundaries automatically according to your input. This approach to 

spot editing maximizes reproducibility while allowing you to refine the detected spot 

pattern. 

 
Note:   

In order to edit spots, you have to select the 'Spot Editing Tool' first. Click on the third 

button in the vertical tool panel at the left of the Dual View window. 

  

Adding a New Spot on the fusion image 

To create a new spot simply click on the center of the undetected spot to let Delta2D 

automatically find a spot at this position. A new spot marker ( ) is created and Delta2D 

will compute the spot's boundary. 

  

Image region before and after adding a spot manually 
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Joining Spots 

To join two or more spots, connect the spot centers with a line-marker: Just click and 

drag with the mouse. Delta2D uses this marker to compute a new spot boundary that 

covers the spots that have been connected by the line-marker. 

 

   

Examples for joined spots. 

Splitting a Spot 

In some cases Delta2D detects one spot where you would rather like to have two or 

more. Click once into the center of the spot that was not detected separately and a spot-

marker will appear. Starting from this marker Delta2D will now compute new spot 

boundaries. Depending on the position of the marker the spot boundaries will vary. 

 

   

Set of spots, detected as one and split with markers 
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Moving and Deleting Spot Markers 

Spot markers can be moved by dragging with the left mouse button. To delete a spot 

marker you can right-click on it. Moving or deleting markers changes spot boundaries and 

it may take some time to compute the new boundaries. 

Removing Spots 

To remove a spot, activate the 'Spot Selection Tool', right click on the respective spot and 

select 'Cancel Spot' from the context menu. To remove a complete region of false positive 

spots, for instance at the gel image borders, you can select groups of spots by dragging a 

rectangle around them and cancel them together. By selecting 'Spots'→'Show Cancelled 

Spots' you can display the cancelled spots with dotted lines. 

Filtering Noise Spots 

While Delta2D usually is excellent in finding spots, some image properties such as strong 

image noise may cause the detection of 'false positive' or 'noise' spots. These segments 

do not have the typical shape when viewed in 3D, and they are generally quite faint. 

You can use the 'Sensitivity' parameter in the Spot detection parameter dialog to suppress 

the detection of background spots. However, Delta2D also computes a 'spot quality' 

value for every detected spot. This value shows how closely a spot represents the 'ideal' 

3D Gaussian bell shape. You can filter spots in accordance to this value like this: 

1.  Open the Quantitation Table by choosing 'Window' -> 'Quantitation Table'. 

2.  In the table, click on the tab for the fused image. 

3.  Locate the spot quality column, and click on the 'filter' button in the column 

header. 

4.  In the filter dialog, check the 'Filter active' check box, then use the sliders to 

adjust the filter settings or insert values as filter borders (a value of 0.02 works 

fine in many cases), 

5.  Press the 'Apply' button to check the effect of your filter immediately, or click 

'OK' when you are done. 

6.  Use the Dual View to check the spots that have been filtered. 

 

We recommend setting the filter in such a way that you see only those spots that you 

would like to remove. Then choose 'Edit->Select all' and 'Cancel -> Cancel Selected Spots'. 
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Finally, to remove the filter on the spot quality column, click on the filter button in the 

column header and uncheck the 'Filter active' checkbox. Now you have cancelled all spots 

with insufficient spot quality. 

 

In summary we have detected spots on the fused image and since the union fusion 

includes all spots occurring on any of the gel images, we have a 'consensus spot pattern' 

for the whole project located on the fused image. 

Transferring Spots 

The next step towards quantitative analysis is to transfer the consensus spot pattern from 

the fusion image to the other gel images where the spots will be quantitated 

automatically. 

 

In the step 4 'Create the Consensus Spot Pattern' in the 'Workflow' window click on the 

fused image 'Transfer Spots...'. The 'Transfer' dialog opens. The default settings will be 

that spots are transferred from the fused image to all the other images of the project. 

Confirm these settings with 'OK'. 

 

Note:   

If an image is not connected to any of the other images or is only connected with the 

'automatic' warp mode  and you have not started the Automatic to find match vectors so 

far, you won't be allowed to transfer spots to that image. If necessary, please check your 

warping strategy in the 'Warping Setup' window ('Window' -> 'Warping Setup') once again. 

  

 

A progress bar indicates how spots are transferred to one image after another and 

quantified. Since we started with the detection result from a union-fused image we get a 

complete expression profile for every spot over the whole set of gel images.  
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Note:   

You can choose either to transfer the boundaries as they appear on the fusion image or to 

adapt the size of the boundaries to the actual spots on the target images. Find this option in 

the Preferences tab 'Spots'. 

  

 

On those images where a certain spot does not contain a signal, Delta2D will nevertheless 

quantitate the images in accordance to the transferred spot boundary. This will result in a 

spot with near-zero quantity.  

 

You have transferred the information where you expect the spot in the single gel images. 

In order to see the quantitative expression profiles choose the menu entry 'Window' -> 

'Quantitation Table'. This will open the Quantitation Table.  

 

Before looking at the table in more detail let us have a quick look at some more visual 

means for the analysis of expression profiles. 

 

Spot boundaries after spot transfer. Choose 'Window'→'Gel Image Regions' to open this view. 

The essential spot pattern is the same on all gels, making 100% spot matching possible. 
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  AAnnaallyyzzee  EExxpprreessssiioonn  PPrrooffiilleess  
 

 

Note:   

For getting a qualitative impression of differences between two images only, simply open 

the Dual View for these images. 

  

Finding Interesting Spots in a Scatter Plot 

For finding interesting spots you can compare 

their expression levels in two images. In the 

spots menu of the Dual View please click on 

'Spots' > 'Show Scatter Plot' to open a graphical 

representation of the spots of these two gel 

images. The position of a spot is determined by 

its normalized volume on each image: in this 

example, the x-position by its quantity in 

Control_01 and the y-position by its quantity in 

the 1min_01 image. Thus, a spot having an 

unchanged volume on both images appears on 

the 45 degree line of this graph, whereas 

induced spots are found in the upper left and 

reduced spots in the lower right part of this 

graph. Now just click on one of the spots in the 

top or bottom of the Scatter Plot and keep an eye on the Dual View. The selected spot 

shape will be highlighted in the Dual View, and the view will scroll to the selected spot if 

necessary. 

  

 
Scatterplot 
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Identifying Interesting Spots by Expression Profiles 

You can view an expression profile of a spot over 

the complete project: in the menu of the Dual 

View, please click on 'Rollups' > 'Expression 

Profiles'. A new window will open, keeping its 

position in front of its parent window: one of the 

so-called 'Rollups'. Make sure that the Spot 

Selection Tool is selected and simply move the 

mouse pointer to a certain spot. The rollup 

dynamically shows the expression profile for this 

spot across the whole project. The height of each 

bar is determined by the relative volume (%Vol) 

of the spot, i.e. the spot's intensity after background subtraction and normalization. Now 

move the mouse pointer to the next spot and watch how the expression profile changes. 

 

Filtering for Interesting Expression Profiles 

Switch to the 'Quantitation Table' by choosing 'Window' > 'Quantitation Table'. The 

quantitation table window shows spot data in three different views:  

 

 'All gel images' view  

Shows spot data for all images in the project showing one expression profile in every 

row in the table. In addition to the %Vol (relative volume) columns this table also 

includes Ratio columns displaying expression ratios as color codes as well as numbers. 

All ratio columns are calculated in accordance to a common ratio master image, to be 

changed in the 'Gel Image and Table Column Visibility dialog' ( ), if necessary. 

Alternatively, you can select a subset of gel images in the Light Table or in the Project 

Explorer (left click and keep CRTL key pressed) only and then click on the table button 

( ). 

 'Statistics' view  

Shows relative volumes as well as averages and relative standard deviations for 

groups, accompanied by t-Test results with respect to the first group. You can also 

compute ratios such as 'mean of group 1min / mean of group control'. Statistics tables 

can also be created for particular groups of a project: Right-click on the respective 

groups in the Light Table or in the Project Explorer and choose 'Open Quantitation 

 
Expression profile rollup displaying the 

spot intensity throughout the whole project 
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Table'. Alternatively, you can select the groups  (left click) and then click on the table 

button ( ). 
 

 
Quantitation Table – ‘Statistics View’ 

 Single gel view  

Shows spot data such as relative volume, area, and ID for spots on a single gel image. 

The spot's quantity is in the % Vol column, it is the result of background subtraction, 

quantitation and normalization. You can open a single gel image table by right-

clicking on the respective image in the Light Table or in the Project Explorer and 

choosing 'Open Quantitation Table' from the context menu. Alternatively, you can 

select the respective image (left click) and then click on the table button ( ). 
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The Quantitation Table is synchronized 

with the other views of Delta2D: Selecting 

an expression profile will select the spot for 

example in the dual view or in the scatter 

plots.  

Delta2D offers powerful tools to identify 

relevant expression profiles in accordance 

to your criteria. If you are e.g. looking for 

spots where intensities in both sample 

groups are increased or decreased by a 

factor of at least 2 relative to the control. 

This factor of 2 should apply to the means 

of the replicate groups, i.e. the mean intensity within group '1min' and '10min' should be 

at least two times greater or smaller than the mean intensity of group 'control'. 

To see only the spots matching these criteria, follow the following steps: 

 

1. Switch to the 'Quantitation Table' and select the 'Statistics' tab. 

2. To see the name of a column either drag the line between two column headers to 

make it wider or simply point to its header and wait until its name appears as a tool 

tip. The name of the column we are looking for is 'Ratio mean % volume 1min / mean 

% volume control'. Click on the top part of the column header labelled 'Filter' to open 

the respective filter. 

3. Insert the filter borders '0.5' and '2' into the fields 'Show values from ... to ...'. 

Alternatively, you can drag the left slider below the histogram. The box 'Filter active' 

will be checked automatically, additionally check the box 'Negated'. The histogram 

highlights the distribution of the ratio values. 

4. Press OK to close the dialog. The 'Quantitation Table' will now show only those 

expression profiles including induced or reduced spots of a factor of at least 2.  

 

Repeat the steps 2 - 4 above for the column 'Ratio mean % volume 10min / mean % 

volume control'. 

Open the Dual View again with the two images 'control_01' and '1min_01'. Only spots 

matching our criteria will be shown there. 

 
Filter Dialog 
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Advanced Statistical Analysis 

Since version 3.6 Delta2D includes advanced multivariate statistics for the analysis of 2D 

gels, including: 

 

 Heat map display of expression profiles 

 Various methods of clustering 

 t-test variations 

 Analysis of Variance (ANOVA)  

 Template matching for expression profiles 

 Principal Component Analysis (PCA) 

 

Statistical analysis in Delta2D is based on the TIGR MeV (The Institute for Genomic 

Research (Rockville, MD, USA) Multiple Experiment Viewer) and tightly integrated into the 

image analysis workflow. With Delta2D's 100 Percent Spot Matching, there are no 

missing values. Matching problems are virtually eliminated, making it especially suitable 

for the methods that were originally developed for DNA microarray analysis. 

 
Note:   

Most statistical algorithms are recommended for being applied to a minimum number of 

data sets while others even demand for such a minimum. The example project is too small 

to rely on results but still helps to understand how statistical analysis in Delta2D works.  

  

 

Open the Quantitation Table (Window -> 

Quantitation Table) and make sure the 

Statistics Table is selected. Hide the 

quantitative data for the fused image: Switch 

to the 'Light Table' window and right-click on 

the thumbnail for the fused image. Select 

'Toggle Visibility' > 'Hide Selected' from the 

context menu. Then switch to the Quantitation 

Table again: The fused image is now excluded 

from the view.  
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Getting a high level overview of expression data - heat map 

 

Press the 'Analyze' button in the top 

left of the statistics table. A new 

analysis window is opened, containing 

the current expression profiles in a 

heat map display. 

 

The legend across the top shows the 

color code for spot intensities. Rows 

are labeled based on the spot labels 

from the gel images. Data is 

normalized / standardized by default 

and sorted as in the statistics table 

before being shown in the heat map. 

 

 

 

Discovering patterns in expression profiles 

 

Clustering of images is a good first 

step in assessing the quality of the 

quantitative data. 

Employ 'hierarchical clustering' to 

show more structure in the data: Press 

the HCL button in the toolbar. Choose 

'Gene Tree', 'Euclidian Distance' as 

metric and 'Complete Linkage'. To 

confirm press OK. The hierarchical 

clustering now groups expression 

profiles in accordance with their 

similarity. 

 

 

 

Heat map for the example project. 

 

Dialog box for HCL settings. 
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The tree represents similarities between expression 

profiles. Click into a subtree to select all protein spots 

of the same cluster. Since the statistics module is also 

synchronized with e.g. the 'Quantitation Table' and 

the Dual View, you can switch there and review the 

selected spots as members of the selected cluster. 

 

If you wish to identify the structure of your experiment 

choose 'Sample Tree' as tree selection. All replicates of 

the same sample should appear in the same cluster 

(subtree). 

 

 

 

Finding profiles for defined templates 

 

With Template Matching, you can 

define a template for an expression 

profile and let Delta2D find spots 

whose expression profiles match the 

template. 

 

Click the 'PTM' button to open the 

dialog box. The lower part of the 

dialog contains a series of sliders. 

Move them roughly to different 

positions to define a sample expression 

profile that shall serve as a template 

and confirm it with 'OK'. 

 

TMeV displays a new Heatmap 

containing the defined template and a 

list of expression profiles that match 

this template. 

  

 

Hierarchical Clustering for 

Expression Profiles. 

 

Expression Profiles matching a Template 
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Finding differentially expressed proteins: Statistical Tests 

 

Delta2D provides methods to 

control the proportion of false 

positives in the result set (False 

Discovery Rate - FDR). Overall, 

the False Discovery Rate 

approach allows one to strike a 

balance between the need to 

find statistically valid proteins of 

interest and the additional cost 

that is associated with following 

up on false positives. 

 

In the t-Test options dialog, 

select "p-values based on 

permutations".  

Select "Stepdown Westfall and 

Young methods" and "maxT" or 

alternatively create bounds for 

the number of false positive 

spots in the result set using the "number of false positive genes should not exceed" or 

"proportion of false positive genes should not exceed" using the other radio button and 

text box. 

 

 

 

Note:   

There is a lot more to know about statistical analysis in Delta2D. Please read on in the 

Delta2D manual. You can access it through the Delta2D help menu or as a PDF file located 

in the installation directory. In Windows, there is a direct link to the manual in the Start 

menu. The manual is also available for download and for online browsing!  

Or contact us at support@decodon.com. 

  

  

 

t-Test parameters. 
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  PPrreesseenntt  RReessuullttss  
 

Reporting and Exporting Results 

Raw data and analysis results from Delta2D can be exported in various formats:  

 Tables can be exported as 'Character Separated Values' (CSV) files or directly as table 

or report to Excel (if this software is installed on your computer).  

 Image views can be exported as standard image files or directly to Microsoft 

PowerPoint. 

 Interactive reports can be created in html format. 

 Picklists can be exported for a variety of pickers in the respective picking formats or 

directly into the Bruker Proteineer database. 

 
Note:   

Reports and picklists include data for expression profiles or spots that have been 'marked'. 

You can mark spots by selecting them and the choosing 'Mark' > 'Mark selected spots' in 

the Quantitation Table or in the Dual View by right click and clicking on 'Mark spot'. 

  

Export Tables to Excel 

When exporting a table, you always export exactly what you see, i.e. the visible columns 

with the visible expression profiles only. Thus you can use the powerful filters of Delta2D 

to select which data you want to export. 

Open the Quantitation Table by choosing 'Window' > 'Quantitation Table'. If you want to 

you can define the filters as described above. Now choose from the table's menu 'Export' 

> 'Export to Excel'. This will directly open an Excel worksheet containing your data.  

Export Image Views into PowerPoint 

Creating PowerPoint presentation slides also takes a few clicks only. 

Open the Dual View for a gel image pair. Zoom in or out and control the visibility of 

objects such as match vectors, spot boundaries and labels (open the rollup 'Overlays' and 

toggle visibility by clicking the respective buttons). Choose 'Export' > 'Export to 

PowerPoint' from the menu. Check both boxes in the next dialog and confirm with 'OK'.  

Follow the instructions on the screen in PowerPoint to create the PowerPoint presentation 

as a slide. Every object visible in the Dual View will be a fully modifiable object in the 

resulting PowerPoint presentation: You can delete unimportant spot boundaries, highlight 
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labels, spots and other objects of interest by changing their color or font size and design 

the presentation making use of the whole set of capabilities provided by PowerPoint. 

 
Note:   

Macros have to be enabled in Excel and PowerPoint to export the data. I.e. macro security 

settings need to changed to 'Medium' or lower. 

  

 

 
A typical PowerPoint export. Each object can be customized  

by using PowerPoint properties and formats. 

 

Create interactive HTML-Reports 

Typically the results of an experiment shall be reported to colleagues or published on a 

website or a scientific paper. To facilitate extracting the relevant information, Delta2D 

provides reports. 
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In the 'Reports' menu you can select from the list of available reports. Delta2D provides 

three standard reports: 

 

 

The 'Project Summary' report includes global information that is available for samples, 

groups, gels, gel images (including the images) and the warping strategy (including the 

respective dual channel images). Click on a dual channel image to let Delta2D open the 

respective Dual View window.  

 

Note:   

You can save the reports using the 'Save' button provided within the report. You have to 

switch to Delta2D where a dialog opens that allows for selecting the location of the saved 

report. When using the 'File' -> 'Save page as ... ' function of your browser you will not 

receive the full content of the reports. 

  

 

 
Spot album report 

 

The 'Spot Album' and the 'Spot Quantities' reports include detailed information about 

expression profiles for marked spots and allow to define parameters to change the 

 
Project Summary 

 
Spot Album 

 
Spot Quantities 
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reports' content. Click on the barchart or the spot ID to select the respective expression 

profile in Delta2D and to receive a detailed report for it.  

Exporting picklists 

With Delta2D you can export picklists for a variety of available spot picking devices. If your 

device is not yet supported please contact the DECODON support team and we will try to 

add it to the set of supported devices. 

 

Picklists include marked spots and the coordinates of all spot labels on the respective gel 

image. Thus, you can export picklists for an image even if no spots have been detected: 

simply label the spots of interest (possibly after activating the auto numbering feature for 

labelling) to include their coordinates in the picklist. 
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Where Can I Find Out More about Delta2D? 

The easiest way to learn more is going to http://www.delta2d.com or contacting us per 

Email to support@decodon.com. We will be happy to answer your questions or to show 

you more in a live web demo. 

 
Note:   

If you need more detailed information about Delta2D, please consult the manual  of Delta2D. 

You can access it through the Delta2D help menu or as a PDF file located in the installation 

directory. In Windows, there is a direct link to the manual in the Start menu. The manual is 

also available on our website for download and for online browsing! 

  

  

 

 

 

 

 

 

 

 

 Your DECODON Support Team 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you have any comment or suggestion regarding this Getting Started Guide or any other 

of our documents we would be happy to hear from you. 
  

http://www.delta2d.com/
mailto:support@decodon.com
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Notes: 
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More Notes: 
 
 
  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  



 


